сряда, 10 юни 2009 г.

Google Chrome за linux

След малко игра тръгна. Интересно ми беше да видя за какво става въпрос и определено съм доволен. Наистина липсват основни неща като flash player и възможност за принтиране, но хората са си казали, че това е developer release.

Свалянето става от тук.

Аз процедирах по следния начин. Понеже няма версия за Slackware или сорс свалих deb пакета и с deb2targz го направих на tar.gz после разгъвам и всички папки по местата им. Личи си коя къде трябва да отиде.

При опит за стартиране на google-chrome започва да реве за липсващи библиотеки. libnss3 и подобни. Проблема си реших като свалих nss3 и го инсталирах.
Става, като се тегли SlackBuild за mozilla-nss от тук (свалям всичко в директорията без nss-3.11.4-with-nspr-4.6.4.tar.gz) и в същата папка слагам nss-3.12-with-nspr-4.7.tar.gz от тук.

Във файла mozilla-nss.SlackBuild заменям
VERSION=${VERSION:-3.11.4}
с
VERSION=${VERSION:-3.12}
и
NSPR=4.6.4
с
NSPR=4.7
за да се изпълни правилно.

След стартирането на mozilla-nss.SlackBuild в /tmp/ се генерира mozilla-nss-3.12-i486-2alien.tgz Инсталира се с installpkg. Сега се налага да се направят няколко линка, защото google-chrome търси имена различни от тези, които имаме. При мен беше достатъчно следното:


ln -s libnss3.so libnss3.so.1d
ln -s libnssutil3.so libnssutil3.so.1d
ln -s libsmime3.so libsmime3.so.1d
ln -s libsmime3.so libssl3.so libssl3.so.1d
ln -s libssl3.so libssl3.so.1d
ln -s libplds4.so libplds4.so.0d
ln -s libplc4.so libplc4.so.0d
ln -s libnspr4.so libnspr4.so.0d


В тоя момент разбирам, че ми трябва и libgconf. Понеже го нямам свалям от SlackBuilds и инсталирам (за да се инсталира, той от своя страна иска ORBit).

След като сложих и тях всичко тръгна.
Шотчето ми тук.

Няма коментари:

Публикуване на коментар